ruby on rails 的老手们,能帮我出个多个环境开发多个项目的主意吗?

情况是这个样子的:
1:我有一个项目现在已经写了大半接近写完了使用开发环境是(ruby 1.9.2 rubygem 1.3.7 rails 2.3.11)
2:现在又要写一个rails项目但是这个项目我想用rails 3 来写,在网上查了下rails 3.2 + ruby 1.9.3 还不错。于是这个时候我就把环境升级到了rails 3.2 rubygems 1.8.17 + ruby 1.9.3
3: 但是问题出现了,当我升级后发现我原来的项目跑不起了,然后我开始修改原来项目中和rails 3 不兼容的地方,改着改着发现我这样不行,有太多的错误和不兼容。我以前听说过Rvm但是没有用过只是晓得是用来管理ruby rails多版本的.
4: 所以我想问一下我能不能在不修改我原来的开发环境(ruby1.9.2 rails 2.3.11 rubygems 1.3.7)下升级到(rails3.2 ruby 1.9.3 rubygems 1.8.17) 然后开发新的项目呢?
5:有用过的同仁吗?能分享一下你们使用的心得和感觉吗?或者对我这种情况有什么好的建议呢?

4 个回答

我推荐你用rvm版本管理你的ruby版本 这样可以解决你的这个问题
我给你贴几个rmv使用指南吧!!
第一肯定是要去官网看看:http://beginrescueend.com/
之后看看别人怎么用:http://www.neocanable.com/rvm-usage/

果断的RVM!

首先, 安装RVM

bash -s stable < <(curl -s https://raw.github.com/wayneeseguin/rvm/master/binscripts/rvm-installer)
source ~/.bash_profile

然后,安装两个ruby

rvm install 1.9.2
rvm install 1.9.3
# 如果你想要1.9.3更快,就用下面的命令(其实是个补丁)来安装
curl https://raw.github.com/gist/1688857/rvm.sh | sh

完成之后,你到你的rails 2.x目录里运行:

rvm use ruby-1.9.2
bundle

到你的rails 3目录里运行:

# 如果你用了上面那个补丁安装方法的话
rvm use ruby-1.9.3-p0-perf
# 普通安装
rvm use ruby-1.9.3
bundle

这样就ok了,有问题再评论

使用gemset

你的回答